Werbeanzeigen

Quersumme einer Zahl mit Excel berechnen – Variante 2

Als Quersumme (oder Ziffernsumme) bezeichnet man üblicherweise die Summe der Ziffernwerte einer natürlichen Zahl. (Quelle: Wikipedia – https://de.wikipedia.org/wiki/Quersumme).

Für die Zahl 123 beträgt die Quersumme daher 1 + 2 + 3 = 6.

Excel besitzt zur Zeit keine Standardfunktion mit der Sie die Quersumme einer Zahl berechnen können. Sie können die Quersumme für eine mehrstellige Zahl aber mit der folgenden Formel in Excel berechnen:

=SUMMENPRODUKT(TEIL(A1;ZEILE(INDIREKT(„1:“&LÄNGE(A1)));1)*1)

Die Formel geht davon aus, dass sich die mehrstellige Zahl, für welche die Quersumme berechnet werden soll, in der Zelle A1 befindet.

Quersumme-02.png
Abbildung: Quersumme einer Zahl mit Excel berechnen

 

Nützliche Links im Internet zu dieser Funktion/Thema

MerkenMerken

Werbeanzeigen
search previous next tag category expand menu location phone mail time cart zoom edit close