Quersumme einer Zahl mit Excel berechnen – Variante 2

Als Quersumme (oder Ziffernsumme) bezeichnet man üblicherweise die Summe der Ziffernwerte einer natürlichen Zahl. (Quelle: Wikipedia – https://de.wikipedia.org/wiki/Quersumme).

Für die Zahl 123 beträgt die Quersumme daher 1 + 2 + 3 = 6.

Excel besitzt zur Zeit keine Standardfunktion mit der Sie die Quersumme einer Zahl berechnen können. Sie können die Quersumme für eine mehrstellige Zahl aber mit der folgenden Formel in Excel berechnen:

=SUMMENPRODUKT(TEIL(A1;ZEILE(INDIREKT(“1:”&LÄNGE(A1)));1)*1)

Die Formel geht davon aus, dass sich die mehrstellige Zahl, für welche die Quersumme berechnet werden soll, in der Zelle A1 befindet.

Quersumme-02.png
Abbildung: Quersumme einer Zahl mit Excel berechnen

 

Nützliche Links im Internet zu dieser Funktion/Thema

MerkenMerken

Das könnte interessant sein Powered by AdWol Online Werbung

Excel-Grundkurs – Aufbau von Formeln — at Excel-Blog – Andreas Thehos

In der sechsten Folge des Excel-Grundkurses geht es um die Verwendung der Grundrechenarten und weit...

INDIREKT mit SVERWEIS in Excel für Verweise auf mehrere Blätter — Excel-Spezialist

Mit der INDIREKT-Formel können wir Formeln mit eigenen Parameter erstellen. Wenn Sie in Excel ...

Excel – SUMMEWENN mit dynamischen Spalten — Bork.Blog

Aus einer Zeiterfassungssoftware wird wöchentlich eine Liste mit Mitarbeiternamen, Projektname...

search previous next tag category expand menu location phone mail time cart zoom edit close