Werbeanzeigen

Doppelte Einträge (Redundanzen) in einer Zeile automatisch verhindern

Wenn Sie verhindern wollen, dass keine doppelten Werte in einer Zeile eingetragen werden, dann können Sie hierfür die Datenüberprüfungen in Excel einsetzen.

So geht´s:

  • Markieren Sie die Zeile, in der Sie die Eingabe von doppelten Werten verhindern wollen (z.B. Zeile 1).
  • Aktivieren Sie im Menüband die Befehlsfolge Registerkarte Daten > Befehlsgruppe Datentools > Befehl Datenüberprüfung.
  • Es öffnet sich das Dialogfeld Datenüberprüfung. Klicken Sie im Listenfeld Zulassen auf  den Eintrag Benutzerdefiniert. Erfassen Sie nun unter Formel =ZÄHLENWENN($1:$1;A1)<2
  • A1 stellt in dieser Formel die aktive Zelle dar. Dieser Bezug muss als relativer Bezug (ohne $) erfasst werden, damit sich die Formel auf alle anderen Zellen in der Zeile 1 entsprechend anpasst.
66
Abbildung: Doppelte Einträge in Zeile 1 über Datenüberprüfung verhindern
  • Bestätigen Sie Ihre Einstellungen, indem Sie auf OK klicken.

Wenn Sie nun versuchen einen doppelten Eintrag in der Zeile 1 zu erfassen, dann werden Sie von Excel daran gehindert.

67

Über die Funktion ZÄHLENWENN() können Sie ermitteln, wie oft der Inhalt einer Zelle in der kompletten Zeile vorkommt. Nur wenn das Ergebnis „<2“ ist, liegt keine Doppel­ein­gabe (Redundanz) vor und Excel nimmt den Wert an.

Wollen Sie doppelte Werte in einer anderen Zeile verhindern, dann müssen Sie die Zeile in der Formel entsprechend anpassen. Wollen Sie z.B. in der zweiten Zeile die Erfassung von doppelten Werten verhindern, dann gehen Sie wie oben beschrieben vor, indem Sie die komplette Zeile 2 markieren. Erfassen Sie dann im Dialogfeld Datenüberprüfung die folgende Formel:

=ZÄHLENWENN($2:$2;A2)<2

Weiterführende Links:

MerkenMerken

Werbeanzeigen
search previous next tag category expand menu location phone mail time cart zoom edit close