Doppelte Einträge (Redundanzen) in einer Spalte automatisch verhindern

Wenn Sie verhindern wollen, dass keine doppelten Werte in einer Spalte eingetragen werden, dann können Sie hierfür die Datenüberprüfungen in Excel einsetzen.

So geht´s:

  • Markieren Sie die Spalte, bei der Sie die Eingabe von doppelten Werten verhindern wollen (z.B. Spalte A).
  • Aktivieren Sie im Menüband die Befehlsfolge Registerkarte Daten > Befehlsgruppe Datentools > Befehl Datenüberprüfung.
  • Es öffnet sich das Dialogfeld Datenüberprüfung. Klicken Sie im Listenfeld Zulassen auf  den Eintrag Benutzerdefiniert. Erfassen Sie nun unter Formel =ZÄHLENWENN($A:$A;A1)<2
  • A1 stellt in dieser Formel die aktive Zelle dar. Dieser Bezug muss als relativer Bezug (ohne $) erfasst werden, damit sich die Formel auf alle anderen Zellen in der Spalte A entsprechend anpasst.
64
Abbildung: Doppelte Werte in Spalte A verhindern
  • Bestätigen Sie Ihre Einstellungen, indem Sie auf OK klicken.

Wenn Sie nun versuchen einen doppelten Eintrag in der Spalte A zu erfassen, dann werden Sie von Excel daran gehindert.

65
Abbildung: Meldung beim Versuch einen doppelten Wert in der Spalte A zu erfassen

Über die Funktion ZÄHLENWENN() können Sie ermitteln, wie oft der Inhalt einer Zelle in der kompletten Spalte vorkommt. Nur wenn das Ergebnis „<2“ ist, liegt keine Doppel­ein­gabe (Redundanz) vor und Excel nimmt den Wert an.

Weiterführende Links:

MerkenMerken

Das könnte interessant sein Powered by AdWol Online Werbung

Excel-Grundkurs – Aufbau von Formeln — at Excel-Blog – Andreas Thehos

In der sechsten Folge des Excel-Grundkurses geht es um die Verwendung der Grundrechenarten und weit...

Excel–Leerschritte stören beim ZÄHLENWENN — Bork.Blog

Eine von mehreren Personen gepflegte Liste wird mit ZÄHLENWENN und SUMMEWENN ausgewertet. Dabe...

Excel – Zellen schützen ohne Blattschutz — Bork.Blog

Der Blattschutz bei Excel verhindert leider das Filtern, Sortieren und einige andere Aktionen. ...

search previous next tag category expand menu location phone mail time cart zoom edit close