Werbeanzeigen

Nachgestellte Minuszeichen nach vorne stellen (Variante mit Formel)

Nachgestellte Minuszeichen nach vorne stellen (1234- in -1234 umwandeln)

Hin und wieder kann es z.B. nach Datenimporten aus anderen Programmen in Excel vorkommen, dass negative Zahlen mit einem nachgestellten Minuszeichen dargestellt werden. Excel interpretiert Zahlen mit nachgestellten Minuszeichen dann nicht als negative Zahlen sondern als Text. Damit Excel diese Daten als negative Zahlen interpretiert, müssen Sie nachgestellte Minuszeichen nach vorne stellen (1234- in -1234 umwandeln).

Nachgestellte Minuszeichen nach vorne stellen
Abbildung: Negative Zahlen werden mit einem nachgestellten Minuszeichen dargestellt

Mit Formel nachgestellte Minuszeichen nach vorne stellen

Mit der folgenden Formel können Sie nachgestellte Minuszeichen nach vorne stellen und so als Text interpretierte Zahlen wieder in „richtige Zahlen“ umwandeln:

=WENN(RECHTS(A1;1)=“-„; LINKS(A1;LÄNGE(A1)-1)*(-1);A1)

nachgestellte Minuszeichen nach vorne stellen

Die Zelle A1 repräsentiert hier die Zelle, welche die Zahl mit einem nachgestellten Minuszeichen enthalten kann.

  • Zunächst wird mit RECHTS(A1;1)=“-“ überprüft, ob das Zeichen am rechten Rand in der Zelle A1 ein Minuszeichen ist =WENN(RECHTS(A1;1)=“-„; LINKS(A1;LÄNGE(A1)-1)*(-1);A1)
    • Sollte dies der Fall sein, dann wird mit der Funktion LÄNGE() die Anzahl der Zeichen in der Zelle A1 ermittelt =WENN(RECHTS(A1;1)=“-„; LINKS(A1;LÄNGE(A1)-1)*(-1);A1)
    • Anschließend wird dieser Wert um 1 für das Minuszeichen am rechten Rand reduziert =WENN(RECHTS(A1;1)=“-„; LINKS(A1;LÄNGE(A1)-1)*(-1);A1)
    • Der um 1 reduzierte Wert wird jetzt an die Funktion LINKS() übergeben, welche die Zahl ohne das Minuszeichen aus der Zelle A1 von links herausliest. =WENN(RECHTS(A1;1)=“-„; LINKS(A1;LÄNGE(A1)-1)*(-1);A1)
    • Anschließend wird diese Zahl mit -1 multipliziert, so dass Sie eine negative Zahl erstellt haben. Diese Zahl wird anschließend als Ergebnis in der Zelle ausgegeben =WENN(RECHTS(A1;1)=“-„; LINKS(A1;LÄNGE(A1)-1)*(-1);A1)
  • Sollte das Zeichen am rechten Rand in der Zelle A1 kein Minuszeichen sein, dann handelt es sich um eine positive Zahl, welche automatisch richtig als Zahl erkannt wird. In diesem Fall wird automatisch der Inhalt der Zelle A1 als Ergebnis ausgegeben =WENN(RECHTS(A1;1)=“-„; LINKS(A1;LÄNGE(A1)-1)*(-1);A1)

Weiterführende Links:

 

Werbeanzeigen
search previous next tag category expand menu location phone mail time cart zoom edit close