Werbeanzeigen

Quersumme eines Datums mit Excel berechnen

Als Quersumme (oder Ziffernsumme) bezeichnet man üblicherweise die Summe der Ziffernwerte einer natürlichen Zahl. (Quelle: Wikipedia – https://de.wikipedia.org/wiki/Quersumme).

Sie können auch die Quersumme von Datumswerten in Excel berechnen.

Für das Datum 08.04.1974 beträgt die Quersumme daher 0 + 8 + 0 + 4 + 1 + 9 + 7 + 4 = 33.

Excel besitzt zur Zeit keine Standardfunktion mit der Sie die Quersumme eines Datums berechnen können. Sie können die Quersumme für einen Datumswert aber mit der folgenden Formel in Excel berechnen:

{=SUMME(TEIL(TEXT(A1;“TTMMJJJJ“);ZEILE(1:8);1)*1)}

Die Formel geht davon aus, dass sich das Datum, für welche die Quersumme berechnet werden soll, in der Zelle A1 befindet. Bei dieser Formel handelt es sich um eine Matrixformel. Bitte beenden Sie die Eingabe dieser Formel daher nicht mit Enter, sondern mit der Tastenkombination Strg + Umschalt + Enter. Daraufhin wird die Formel automatisch in geschweifte Klammern eingerahmt.

Quersumme-Datum.png
Abbildung: Quersumme eines Datums mit Excel berechnen

Hinweis: Die geschweiften Klammern am Anfang und Ende der Formel dürfen nicht manuell über die Tastatur erfasst werden. Sie werden automatisch durch die Tastenkombination Strg + Umschalt + Enter hinzugefügt.

Diese Matrixformel geht von einen 8-stelligen Datumsformat mit dem Formatcode TTMMJJJJ aus. T steht hier für Tag, M für Monat und J für Jahr. Auch wenn der Wert in der Zelle A1 nicht als Datum formatiert ist, würde die Zahl in das Format TTMMJJJJ durch die Funktion TEXT(A1;“TTMMJJJJ“) umgewandelt werden. Danach wird jede einzelne Ziffer aus diesem Datum, wie oben beschrieben, addiert.

Wollen Sie die Quersumme eines 6-stelligen Datumswerts bilden, dann müssen Sie die Formel anpassen. Soll die Quersumme aus einem Datumswert ermittelt werden, in welchem die Jahreszahl nur 2-stellig berücksichtigt werden soll, dann ändern Sie den Formatcode und die Datumslänge wie folgt ab:

{=SUMME(TEIL(TEXT(A1;“TTMMJJ„);ZEILE(1:6);1)*1)}

Die Quersumme für den 08.04.74 würde dann 23 betragen (0 + 8 + 0 + 4 + 7 + 4). Auch wenn das Datum in der Zelle A1 als 08.04.1974 dargestellt wird (8-stellig), würde die Matrixformel {=SUMME(TEIL(TEXT(A1;“TTMMJJ„);ZEILE(1:6);1)*1)} nur 6 Ziffern addieren. Die Jahreszahl 1974 würde nur mit 74 bei der Quersumme entsprechend berücksichtigt werden.

 

Nützliche Links im Internet zu dieser Funktion/Thema

MerkenMerken

Werbeanzeigen
search previous next tag category expand menu location phone mail time cart zoom edit close